Macwester prop issue

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3121
    Craig BodsworthCraig Bodsworth
    Participant

    Hi all
    I’m very pleased to have recently purchased a macwester 26.
    I have an issue with the prop. I got the boat underway but very quickly lost all power. Engine revs gearbox is engaged and shaft is spinning but no power. I assumed the prop had fallen off but after drying the boat on the bank its still there!
    Does anyone know what type of fitting the prop may have? Engine is a bukh 20hp. I’m gonna attempt to get at the prop at the weekend but it’s half submerged in mud so gonna be tricky so a head ups may be fruitful.
    Many thanks

    #3124
    Chris NixonChris Nixon
    Keymaster

    Hi first check the gear box oil
    If the prop is spinning it will make a noise check the key way on the inside first then the prop
    You can give me a call
    Chris

    #3142
    Craig BodsworthCraig Bodsworth
    Participant

    Didn’t suspect gearbox as shaft is spinning lovely. Key way inside? I assumEd woodruff key in prop was the issue

    #3143
    Craig BodsworthCraig Bodsworth
    Participant

    Call would be great Chris 07479 030188 thanks

    #3144
    Craig BodsworthCraig Bodsworth
    Participant

    Sussed it! The clamp on the shaft joint was loose. Simple fix should refloat her tomorow night

    #3154
    Chris NixonChris Nixon
    Keymaster

    Glad you got it sorted.
    Chris

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.